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Important Notice 

SUNPLUS INNOVATION TECHNOLOGY INC. reserves the right to change this documentation without prior 

notice.  Information provided by SUNPLUS INNOVATION TECHNOLOGY INC. is believed to be accurate and 

reliable.  However, SUNPLUS INNOVATION TECHNOLOGY INC. makes no warranty for any errors which may 

appear in this document.  Contact SUNPLUS INNOVATION TECHNOLOGY INC. to obtain the latest version of 

device specifications before placing your order.  No responsibility is assumed by SUNPLUS INNOVATION 

TECHNOLOGY INC. for any infringement of patent or other rights of third parties which may result from its use. 

In addition, SUNPLUSIT products are not authorized for use as critical components in life support systems or 

aviation systems, where a malfunction or failure of the product may reasonably be expected to result in significant 

injury to the user, without the express written approval of SunplusIT. 
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1   SPMC65X In-Circuit Emulator 

1.1   Description 

Sunplus Innovation Technology Company Limited, the world famous corporation in IC 
design, specializes in developing high-quality integrated circuit (IC).  Our vision is 
“Technology for Easy Living”, that is, to provide customers with satisfying products and 
knight service by the powerful IC design and system application capabilities.  With many 
core technologies of multi-media, microprocessors, and digital signal processors (DSP), 
SunplusIT has developed a wide variety of products, such as LCDs, microcontrollers, 
multi-media, speech ICs, mp3/mp4, and various ASICs.  Promisingly, the giant wheel of 
innovative design keeps rolling forward day after day. 

SPMCX MCU, the industrial control MCU developed by SunplusIT, plays its significant role 
in the MCU field with high noise immunity, low cost high performance, and comprehensive 
technical-service.  SPMCX MCU includes SPMC65X and SPMC75X, thereinto, The 
SPMC65X is suitable in general-purpose controller, Industrial equipments, computer 
peripheral controller, home appliance, etc.  The SPMC75X is designed for inverter-fed 
motor driver, power electronics, home application and inverter control system, etc. 

SPMC65X In-Circuit Emulator is used for SPMC65X in-circuit emulating and OTP 
(One-Time Programmable IC) programming.  Following are the related configurations: 

 One SPMC65X in-circuit emulator 

 One 9V power supply 

 One emulator adapter 

 Two flat cables 

 One USB cable 

 One CD (including IDE and rich product information) 

 One user guide 

1.2   Structure Introduction 

The In-Circuit SPMC65X In-Circuit Emulator for SPMC65x family is shown as Figure 1-1. 
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Figure 1-1  SPMC65X In-Circuit Emulator 

− A: USB socket 

− B: 9V power supply input 

− C: In-Circuit Programming fixture for OTP type IC(upper-aligned fixed) 

− D: Power switch 

− E: Extended Connectors 

− F: RESET 

− G: SLEEP indicator, yellow 

− H: RUN indicator, green 

− I: POWER indicator, red 

1.3   SPMC65X In-Circuit Emulator Operation 

 Connect the in-circuit SPMC65X In-Circuit Emulator with PC 

Just connect a USB cable square end to the SPMC65X In-Circuit Emulator (A in Figure 1-1) 
and the flat end to PC USB interface. 

 Connect the in-circuit SPMC65X In-Circuit Emulator with user’s target board 

SPMC65X family SPMC65X In-Circuit Emulator reserves some extension connectors for 
connecting user self hardware board and SPMC65X family daughter board, shown in 
Figure 1-2.   User can use the emulated daughter boards which are pin compatible with 
SPMC65X family microcontrollers to connect to product hardware board for system 
development (such as SPMC65P2408A versus SPMC65P2408A SPMC65X In-Circuit 
Emulator adapter).  After connection via the extension connectors, debug can be 
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performed.  

 

 

Figure 1-2  Extension Connectors to SPMC65X In-Circuit Emulator Adapter 

Refer to Figure 1-3 for extension connector schematic illustration: 
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Figure 1-3  Extension Connector Schematic Illustration 

 Power Supply 

There are three kinds of power supply modes for SPMC65X family SPMC65X In-Circuit 
Emulator. 

− A switch shown as ‘A’ in Figure 1-1 is used to switch the supply power.  While 
switching to “OFF” side, the supply power of SPMC65X family SPMC65X In-Circuit 
Emulator is independent of user’s target board. The working power of SPMC65X 
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In-Circuit Emulator is 5Vdc converted from DC-9V adaptor input, shown as ‘B’ in 
Figure 1-1. In this operation, SPMC65X In-Circuit Emulator and user’s target board 
have a common ground and independent power supply. 

− While switching to “ON” side, shown as ‘D’ in Figure 1-1, SPMC65X In-Circuit 
Emulator and target board have the same VCC and GND. User can select the 
working power supplied from DC-9V adaptor ( ‘B’ in Figure 1-1) or user’s target 
board. 

Note: 

The highest current that the SPMC65X In-Circuit Emulator can offer for user’s target board is 500mA. 

− Check the SPMC65X In-Circuit Emulator being not powered (in B of Figure 1-1), 
then switch the power (in D of Figure 1-1) to “ON”.  Supply power to the target 
board, and in this operation, SPMC65X In-Circuit Emulator and user’s target board 
have a common power supply. 

Note: 

 Target board supplies 5V (recommend) for SPMC65X In-Circuit Emulator; once the voltage is over 6V, the 
over-voltage protection circuit will disable the connection. 

 The over-voltage protection circuit in SPMC65X In-Circuit Emulator is power supplied via USB port, thus 
first of all do connect the USB. 

The power indicator on the SPMC65X In-Circuit Emulator (see I in Figure 1-1) is lighted 
when the emulator is powered on. 

 Debug 

The complete emulation system let user finish all design follow from coding, debugging, 
emulating, to programming device.  SunplusIT establishes an overall development 
environment which combines SPMC65X Family Emulator and FortisIDETM to let user 
develop product design follow (refer to SPMC65x Programming Guide or 
www.SunplusITmcu.com).  When indicator H is on, the system is in debug or 
programming cycle; when G is on, system enters SLEEP mode. 

 Programming 

Connect pin 1 of the MCU to the top left of the ICP fixture and press it tightly (see Figure 
1-4), then program the MCU through Q-Writer. 
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Figure 1-4  In-Circuit Programming fixture 
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2   Q-Writer 

The Q-Writer is a SunplusIT new developed programming tool, which let user be able to 
complete all design flow in the SPMC65X family development environment.  This chapter 
will describe how to program and usage of serial number and product information; 
moreover, it also introduces how to set the security via Q-writers. 

You can install SPMC65 development environment Fortis IDE and Q-Writer at the same 
time and refer to www.SunplusITmcu.com for the last software version. 

2.1   General Description 

The Q-Writer is a SunplusIT new developed programming tool which is dedicated for the 
SPMC65X family. Q-Writer is built with a friendly operation interface (shown in Figure 2-1) 
and concise hardware architecture. The new generation programming tool provides many 
advantages like more convenient usage, high reliability and low cost etc. 

Menu bar

Program memory
window

IC content
window

Statistic
window

Message
window Status

window

Tool bar

 

Figure 2-1  Q-Writer Interface 

Program Memory Window: This window records the downloaded binary file and it is also 
the source for programming. 

IC Content Window: This window records the content of OTP. While something error 
happened during operation, the window shows the error address and read back data. 

Statistic Window: This window is used to manage the programmed quantity. 

Message Window: To enable or disable exhibited items of this window by selecting the 
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checkboxes of option. 

Status Window: Q-Writer shows all of the operating state in this window. User can see the 
whole  operation procedure clearly. 

2.2   Q-Writer Settings 

 Select [Setting] → [Option], User can see the setting window as Figure 2-2. 

 

Figure 2-2  Setting Window 

“Message Windows” option is to enable or disable exhibited items of this window by 
selecting the checkboxes of option.  This window, as shown in Figure 2-3, is called by 
[Windows] → [Message Window]. 

 

Figure 2-3  Message Window 

If users uncheck the security setting selection, the system will not display a confirmation 
window before securing IC. 

Select [Setting], user can set following functions: 

 Program Statistic: The function is the same as the icon of toolbar to enable/disable 
statistic function. 

 16 Bytes per Row: The function controls the arrangement amount of per row. If 
enabling the function, per row of memory window shows 16 bytes data or else the byte 
is auto arranges according to the window’s size variation. 
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 Show ASCII Code: Show the corresponding ASCII code against the binary data of 
memory window. 

2.3   Programming Steps via Q-Writer 

 Starting Q-Writer 

− Method one: Execute Q-Writer-V1.0.0.exe directly. 

− Method two: After opening FortisIDE, user can start Q-Writer by pressing  on 
the toolbar or select [Tools] → [Q-Writer]. 

Note: 

When starting Q-Writer, FortisIDE is forbidden to enter debug mode. Even if FortisIDE has gone into debug 
mode, it still goes back to normal state as long as starting Q-Writer. 

 Blank Check 

Select [Function]→[ Blank Check], check whether IC is blank or not.  At the same time, 
Q-Writer reads out the IC data to IC content window.  If this function failed at some 
address, the system goes to the wrong address and highlights the data with red in the IC 
content window. 

 Select 

Select [Device]→[Select], open the device selection menu as follows. User must select a 
device after executing Q-Writer at the first time. The system also records the last selection 
device in the message window; hence the last selection device is the default setting if 
Q-Writer is restarted. 

 

Figure 2-4  Select Device 

 File 
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− Select [File] → [Open] to open and download the *.bin or *.tsk file to “Program 
Memory Window”. 

− Select [File] → [Recent Files].  Record at most 4 last opened files. 

 User Information 

− Serial number  

Q-Writer uses 4 bytes to be the serial number locations from 0x7FF0 to 0x7FF3, 
shown in Figure 2-5. 

 

Figure 2-5  Product Serial Number 

♣ Start Address: The start address of serial number is 0x7FF0.  0x7FF0 is the LSB 
and 0x7FF3 is the MSB. 

♣ Size (1 to 4 bytes): User can decide how many bytes of serial number to be used 
through setting this  item. 

♣ Initial Number: The item is used to input the preliminary serial number. When 
user finishes the setting, the input data will update to program memory window. 
The default value of unused bytes is 0xFF. 

♣ Mode: The item lets user be able to operate the serial number setting with fixed 
mode or auto mode.  In fixed mode, the increment item becomes gray area 
and the serial number is fixed as initial number  setting; in auto mode, user 
can decide the increment value and the serial number has regular variation in 
 accordance with this value. There are two ways to change the increment value, 
which are positive or negative counting. 

− Product Info: 

0x7FF4~0x7FFF total 12 bytes are used to be the product information location.  User 
can use free those locations to record configured product information such as 
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production date and factory.  The default value of those bytes is 0xFF, shown in 
Figure 2-6. 

 

Figure 2-6  Product Information 

 Program 

This command is used to program OTP device according to the content of program 
memory window.  At the same time, Q-Writer reads out the IC data to IC content window.  
If this function failed at some address, the system goes to the wrong address and 
highlights the data with red in the IC content window.  Once executing this function, 
Q-Writer also executes verify function to ensure the programming reliability in the 
meanwhile. 

 Verify 

Verify function is used to check the data of source code and target OTP.  While verifying 
IC, Q-Writer reads out the IC data to IC content window.  If this function failed at some 
address, the system goes to the wrong address and highlights the data with red in the IC 
content window. 

 Secure 

This command is used to enable/disable IC encryption. After setting up this function, the 
device will be secured and not be allowed to read.  User must program and verify device 
before starting security operation. SPMC65X family microcontrollers just allow the IC 
content of some addresses to be read, which like device configuration registers, user 
information, and the last 16 bytes of program memory (0xFFF0~0xFFFF). The others are 
shown as 0x00. 

2.4   Operation Mode 

This menu is used to select the continuous operation mode that suitable for mass 
production.  Please follow the steps below. 

(1) Open [Operation Mode] to select: 
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− A. Blank  Program: this command will auto run Blank Check and Program 
continuously.  If any failed at some address, the system stops operating and 
highlights the error. 

− B. Blank  Program  Verify: System will perform Blank check, Program and 
Verify continuously.  If any failed at some address, the system stops operating and 
highlights the error. 

− C. Blank  Program  Verify  Secure: System will perform Blank check, 
Program, Verify and Secure continuously.  If any failed at some address, the 
system stops operating and highlights the error. 

”A. Blank  Program” is the default mode. 

(2) Enable Statistic Window (refer to Figure 2-7) to manage the programmed quantity, 
shown in Figure 2-8. 

 

Figure 2-7  Statistic Window 

 

Figure 2-8  Quantity of Programmed Target 

(3) Open and download the *.bin or *.tsk file to “Program Memory Window”. 

(4) Click   or select [Function] → [Auto Run] for programming automatically.  Click 

 once and perform the selected programming mode one time.  Figure 2-7 shows 
the programming statistic information. 

 Pass: Record the quantity of programmed successfully IC.  
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 Fail: Record the quantity of programmed failure IC.   

 Total: The sum of pass and fail IC.   

 Target: Set the expectative programmed quantity. 

2.5   Toolbar 

 
Open the source file with binary format. User must download a binary code to enable all 
of Q-writer functions 

 Save the content of program memory as another path. 

 Select device. User has to select a correct device to operate Q-Writer. 

 Execute auto run (continuous) function. 

 Execute blank check function. 

 Execute program function. 

 Execute verify function. 

 Execute read function. 

 Enable serial number function. 

 Execute security function. 

 Enable/Disable statistic function. 

 

Select probe. There are two kinds of items to select the 
suitable probe.  If the probe selection item is ‘Auto 
Detect’, the system will detect plugged probe 
automatically. 
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E_mail: mcu@SunplusIT.com.cn  

Tel: 010-62981668--2930, 2931, 2932, 2933 
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Fax:   010-62962425 

Addr: 5F, NO.1, Zhongli Science & Technology Park, 

      Shangdi Information Industry Base, Haidian District, 
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Post Code: 100085 

 


